Quality issues with the Canadian dial in numbers
Incident Report for Join.me
Resolved
The LogMeIn Technical Operations Team has completed testing our Applications, all alerts have cleared, and this issue is closed. Please feel free to reach out to our Customer Care team by calling (866) 478-1805 should you have questions or comments.
Posted over 1 year ago. May 16, 2018 - 08:11 UTC
Identified
The issue has been identified and is affecting the toll (local) dial in numbers. We are working with our Canadian partner on the resolution.
Posted over 1 year ago. May 15, 2018 - 21:33 UTC
Investigating
We are currently investigating reports of intermittent quality issues using the Canadian dial in numbers. While the problem is being investigated please try using your Computer audio (VoIP) or use this link for more dial in numbers.
http://help.join.me/knowledgebase/articles/149448-international-conference-numbers

We apologize for any disruption this may cause you and your meeting participants.
Posted over 1 year ago. May 15, 2018 - 21:22 UTC
This incident affected: join.me.