Connectivity issues
Incident Report for Join.me
Resolved
At this time, we have confirmed that the join.me service is operational. Thank you for your patience while this incident was resolved.
Posted over 2 years ago. Feb 15, 2017 - 09:20 UTC
Investigating
We are currently investigating sporadic reports of users experiencing network errors on the website and / or connectivity issues when launching the join.me desktop application. We apologize for any disruption this may cause you and your meeting participants.
Posted over 2 years ago. Feb 14, 2017 - 10:51 UTC