Join.Me - Issue resolved
Incident Report for Join.me
Resolved
LogMeIn has confirmed that the identified issue has been resolved completely and all systems are operational at this time.

We will conduct an internal investigation of this issue and make appropriate improvements to our systems to help prevent or minimize future recurrence.
Posted 10 months ago. Jan 02, 2019 - 21:36 UTC
Update
We are continuing to monitor for any further issues.
Posted 10 months ago. Jan 02, 2019 - 20:05 UTC
Monitoring
At this time, we have addressed the identified issue and will continue to monitor the situation.
Posted 10 months ago. Jan 02, 2019 - 20:04 UTC
Update
As of 11:35 PST all toll-free impact has been mitigated. Toll-based customers in Chicago calling local Chicago numbers may still be impacted and may use VOiP as a workaround for now while our vendor works to resolve these issues.
Posted 10 months ago. Jan 02, 2019 - 20:00 UTC
Identified
The NOC has identified an issue related to an upstream vendor which is impacting some Join.me customers in the Chicago area attempting to use toll free audio, as well as our North American customer care toll free numbers.

Our team is now actively working to resolve the issue, and we will provide another update shortly.
Posted 10 months ago. Jan 02, 2019 - 19:24 UTC
This incident affected: join.me.