Connectivity issues
Incident Report for Join.me
Resolved
At this time, we have confirmed that the join.me service is operational.

Thank you for your patience while this incident was resolved. We apologize for any disruption caused to you and your meeting participants by this issue.
Posted over 1 year ago. May 09, 2018 - 10:59 UTC
Monitoring
At this time, the join.me service is working as expected. We will continue to monitor the service closely. We apologize for any disruption that this may have caused.
Posted over 1 year ago. May 09, 2018 - 10:11 UTC
Identified
The issue has been identified and we are working to get this issue resolved as quickly as possible.
Posted over 1 year ago. May 09, 2018 - 09:30 UTC
Investigating
We are currently investigating sporadic reports of users experiencing network errors on the website and / or connectivity issues when launching the join.me desktop application. We apologize for any disruption this may cause you and your meeting participants.
Posted over 1 year ago. May 09, 2018 - 08:35 UTC
This incident affected: join.me.