join.me site is unavailable
Incident Report for Join.me
Resolved
We have resolved the issue which has caused website and connectivity errors. We're sorry for the inconvenience.
Posted over 2 years ago. Jan 24, 2017 - 17:30 UTC
Monitoring
The temporary outage should be resolved by now, however we are closely monitoring the events.
Posted over 2 years ago. Jan 24, 2017 - 17:14 UTC
Identified
We have received several reports about the join.me site being unavailable. We are closely investigating the possible causes. We will update you as soon as we have more information.
Posted over 2 years ago. Jan 24, 2017 - 17:09 UTC