join.me is slow to load
Incident Report for Join.me
Resolved
At this time, we have confirmed that the join.me website is operational.

Thank you for your patience while this incident was resolved. We apologize for any disruption caused to you and your meeting participants by this issue.
Posted about 1 year ago. Jun 18, 2018 - 14:23 UTC
Monitoring
At this time, the join.me website is now working as expected. We will continue to monitor the site closely. We apologize for any disruption that this may have caused.
Posted about 1 year ago. Jun 18, 2018 - 14:12 UTC
Investigating
We are currently investigating reports of the join.me website being slow to load. We apologize for any disruption this may cause you and your meeting participants.
Posted about 1 year ago. Jun 18, 2018 - 14:07 UTC
This incident affected: join.me.