Network error
Incident Report for Join.me
Resolved
At this time, we have confirmed that the join.me service is operational, however we're still actively monitoring our performance.
Thank you for your patience while this incident was resolved. We apologize for any disruption caused to you and your meeting participants by this issue.
Posted over 2 years ago. Mar 08, 2017 - 16:59 UTC
Investigating
We are currently investigating reports of users from West Europe receiving service errors when starting or joining a meeting. We apologize for any disruption this may cause you and your meeting participants.
Posted over 2 years ago. Mar 08, 2017 - 16:50 UTC