Homepage and help page loading issues in West-Europe
Incident Report for Join.me
Resolved
At this time, we have confirmed that the join.me service is operational, however we're still actively monitoring our performance.
Thank you for your patience while this incident was resolved. We apologize for any disruption caused to you and your meeting participants by this issue.
Posted about 2 years ago. Aug 17, 2017 - 11:02 UTC
Monitoring
Our engineering team deployed a fix on join.me website. In the meantime, our 3rd party service provider is also fixing the issue. At this time, the join.me website is working as expected. We will continue to monitor the site closely.
Posted about 2 years ago. Aug 16, 2017 - 17:01 UTC
Identified
We have identified an issue affecting the appearance of some of the text on the join.me website. This issue is isolated to users in the West EU region. This is being caused by a 3rd party service provider and is currently under investigation. We apologize for any inconveniences during this time.
Posted about 2 years ago. Aug 16, 2017 - 13:57 UTC
Investigating
We are currently investigating reports of users having trouble reaching help.join.me.
Posted about 2 years ago. Aug 16, 2017 - 10:13 UTC