Join.Me - Intermittent connectivity issues
Incident Report for Join.me
Resolved
We have confirmed that the issue has been resolved completely and all systems are 100% operational at this time.

We will conduct an internal investigation of this issue and make appropriate improvements to our systems to help prevent or minimize future recurrence.
Posted 4 months ago. May 07, 2019 - 01:36 UTC
Monitoring
Our engineers have corrected the issue and we are confirming that all services are functional.

We will continue to monitor the situation and will provide a final update shortly.
Posted 4 months ago. May 07, 2019 - 01:30 UTC
Identified
Our engineers have identified the cause of the issue and are working to restore proper functionality.

We will provide another update shortly once the issue has been mitigated.
Posted 4 months ago. May 07, 2019 - 01:18 UTC
Investigating
We are actively investigating reports that some Join.Me customers in the US may be experiencing intermittent connectivity issues when using the products.

We will provide another update shortly.
Posted 4 months ago. May 07, 2019 - 01:10 UTC
This incident affected: join.me.