join.me website is unavailable
Incident Report for Join.me
Resolved
At this time, we have confirmed that the join.me website is operational.

Thank you for your patience while this incident was resolved. We apologize for any disruption caused to you and your meeting participants by this issue.
Posted about 1 year ago. Jul 27, 2018 - 15:41 UTC
Monitoring
At this time, the join.me website and application now working as expected. We will continue to monitor the site closely. We apologize for any disruption that this may have caused.
Posted about 1 year ago. Jul 27, 2018 - 15:38 UTC
Identified
We have confirmed that users are experiencing an issue with the join.me website and application We are working to get this issue resolved as quickly as possible.
Posted about 1 year ago. Jul 27, 2018 - 15:25 UTC
This incident affected: join.me.