Increased delay in screen sharing
Incident Report for Join.me
Resolved
This incident has been resolved.
Posted 9 months ago. Jan 23, 2019 - 17:19 UTC
Monitoring
Customers should start seeing improvements to screen share quality.
Posted 9 months ago. Jan 23, 2019 - 13:56 UTC
Identified
We are getting reports of people experiencing an increased delay sharing their screen. The team identified that participants in new conferences might connect to our servers on suboptimal routes, especially for meetings originating from Eastern United States.
The team is working on adjusting the georouting to mitigate the issue.
Posted 9 months ago. Jan 22, 2019 - 20:22 UTC