join.me service is unavailable
Incident Report for Join.me
Resolved
At this time we have confirmed that the join.me service is operational.
Thank you for your patience while this incident was resolved. We apologize for any inconvenience caused to you and your meeting participants by this issue.
Posted almost 2 years ago. Nov 06, 2017 - 21:40 UTC
Monitoring
At this time, the join.me service is now working as expected. We will continue to monitor the site closely. We apologize for any disruption that this may have caused.
Posted almost 2 years ago. Nov 06, 2017 - 21:22 UTC
Identified
One of our 3rd party service provider is having availability issue that is affecting our services. We are actively working on mitigation and recovery.
Posted almost 2 years ago. Nov 06, 2017 - 20:55 UTC
Investigating
We have confirmed that users are experiencing an issue with the join.me website and application. We are working to get this issue resolved as quickly as possible.
Posted almost 2 years ago. Nov 06, 2017 - 20:17 UTC